Instala OpenERP 7.0 de forma automática en CentOS 6.5

Script para instalar de forma automatica OpenERP 7.0 en CentOS 6.5.  

Visualiza script –> instala_OpenERP

1–> Copia contenido del script en fihero: instalar-OpenERP-7.0_CentOS-6.5.sh .

2–> Asigna permisos de Ejecución como su:

          $chmod +x  instalar-OpenERP-7.0_CentOS-6.5.sh

3–> Ejecuta el script como su:

           $./instalar-OpenERP-7.0_CentOS-6.5.sh

_________________________________________________________________________

Archivos de Configuración a revisar:

1–> /var/lib/pgsql/9.3/data/postgresql.conf

Eliminamos comentario #, en la línea correspondiente, e incluso cambiamos el número de puerto para mayor seguridad.

port = 5432

Reiniciamos los servicios a continuación:

service postgresql-9.3 restart

service openerp restart

2–> /var/lib/pgsql/9.3/data/pg_hba.conf

Nos fijamos al final del fichero:

# TYPE DATABASE USER ADDRESS METHOD

# “local” is for Unix domain socket connections only
local all all peer
# IPv4 local connections:
host all all 127.0.0.1/32 ident
# IPv6 local connections:
host all all ::1/128 ident
# Allow replication connections from localhost, by a user with the
# replication privilege.
#local replication postgres peer
#host replication postgres 127.0.0.1/32 ident
#host replication postgres ::1/128 ident
host all all 0.0.0.0/0 md5

Aquí asignamos las redes permitidas o no, y el nivel de confianza o encriptación: md5, peer, trust, etc, …..

 3–> /etc/openerp-server.conf

Añadimos archivo de log:
logfile = /var/log/openerp/openerp-server.log

Si NO existe Directorio, lo creamosy asignamos su propiedad a openerp como root:

mkdir /var/log/openerp

chown openerp:root/var/log/openerp

Reiniciamos servicios:

service postgresql-9.3 restart

service openerp restart

Debemos comprobar el OK

[root@localhost etc]# service openerp restart
Deteniendo OpenERP Server Daemon (openerp-server): [ OK ]
Iniciando OpenERP Server Daemon (openerp-server): [ OK ]

Ahora desde nuestro navegador : localhost:8069

 

 

 

 

2936

2 comentarios sobre “Instala OpenERP 7.0 de forma automática en CentOS 6.5”

  1. hola, favor me puedes ayudar…. me sale despues del script: FALLO
    este es el error:
    [root@localhost /]# openerp.service -xn
    bash: openerp.service: comando no encontrado…
    [root@localhost /]# systemctl status openerp.service
    openerp.service – LSB: Launches the OpenERP server.
    Loaded: loaded (/etc/rc.d/init.d/openerp)
    Active: failed (Result: timeout) since dom 2014-09-14 10:57:15 ECT; 9min ago
    Process: 18541 ExecStart=/etc/rc.d/init.d/openerp start (code=exited, status=0/SUCCESS)
    CGroup: /system.slice/openerp.service
    ├─ 1410 /usr/bin/python /usr/bin/openerp-server -c /etc/openerp-server.con…
    ├─18330 /usr/bin/python /usr/bin/openerp-server -c /etc/openerp-server.con…
    ├─18544 /usr/bin/python /usr/bin/openerp-server -c /etc/openerp-server.con…
    ├─21625 /usr/bin/python /usr/bin/openerp-server -c /etc/openerp-server.con…
    └─22182 /usr/bin/python /usr/bin/openerp-server -c /etc/openerp-server.con…

    sep 14 10:52:16 localhost.localdomain openerp[18541]: File “/usr/lib64/python2.7/Bas…d
    sep 14 10:52:16 localhost.localdomain openerp[18541]: SocketServer.TCPServer.server_…)
    sep 14 10:52:16 localhost.localdomain openerp[18541]: File “/usr/lib64/python2.7/Soc…d
    sep 14 10:52:16 localhost.localdomain openerp[18541]: self.socket.bind(self.server_a…)
    sep 14 10:52:16 localhost.localdomain openerp[18541]: File “/usr/lib64/python2.7/soc…h
    sep 14 10:52:16 localhost.localdomain openerp[18541]: return getattr(self._sock,name…)
    sep 14 10:52:16 localhost.localdomain openerp[18541]: error: [Errno 98] La direcció…o
    sep 14 10:57:15 localhost.localdomain systemd[1]: openerp.service operation timed ou….
    sep 14 10:57:15 localhost.localdomain systemd[1]: Failed to start LSB: Launches the ….
    sep 14 10:57:15 localhost.localdomain systemd[1]: Unit openerp.service entered faile….
    Hint: Some lines were ellipsized, use -l to show in full.
    [root@localhost /]#

    1. Hola: Acabo de actualizar el Script unicamente para Postgres 9.3 y funciona perfectamente. Has comprobado los ajustes de configuración que te recomiendo ?. Supongo que los repositorios que utilizas son como mínimo el base, epel, y puias (en este mismo blog hay un script para instalarlos de forma automática). Reportas las líneas cortadas en lo mas importante. Parece que pudieras tener un error de socket o en alguna dirección. El script esta probado para CentOS 6.5. No lo he probado todavia para CentOS 7.x, me dá la impresión que es la versión que utilizas.

Deja una respuesta

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *

Este sitio usa Akismet para reducir el spam. Aprende cómo se procesan los datos de tus comentarios.

Gnu con Linux, Tips & +

Este sitio web utiliza cookies para que usted tenga la mejor experiencia de usuario. Si continúa navegando está dando su consentimiento para la aceptación de las mencionadas cookies y la aceptación de nuestra política de cookies, pinche el enlace para mayor información.plugin cookies

ACEPTAR
Aviso de cookies